• Uncategorized

About linux : Installing-64bit-only-NVidia-driver-on-ubuntu-2204-closed

Question Detail

I am trying to install an NVidia driver on Ubuntu 22.04 using:

$ sudo apt-get install nvidia-driver-515

Examine the following packages which will be installed if I continue:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  dctrl-tools dkms gcc-12-base:i386 libatomic1:i386 libbsd0:i386 libc6:i386 libcom-err2:i386 libcrypt1:i386 libdrm-amdgpu1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386
  libegl-mesa0:i386 libegl1:i386 libelf1:i386 libexpat1:i386 libffi8:i386 libgbm1:i386 libgcc-s1:i386 libgl1:i386 libgl1-mesa-dri:i386 libglapi-mesa:i386 libgles2:i386 libglvnd0:i386 libglx-mesa0:i386
  libglx0:i386 libgssapi-krb5-2:i386 libicu70:i386 libidn2-0:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 libllvm13:i386 liblzma5:i386 libmd0:i386 libnsl2:i386 libnss-nis:i386
  libnss-nisplus:i386 libnvidia-cfg1-515 libnvidia-common-515 libnvidia-compute-515 libnvidia-compute-515:i386 libnvidia-decode-515 libnvidia-decode-515:i386 libnvidia-encode-515 libnvidia-encode-515:i386
  libnvidia-extra-515 libnvidia-fbc1-515 libnvidia-fbc1-515:i386 libnvidia-gl-515 libnvidia-gl-515:i386 libopengl0:i386 libsensors5:i386 libssl3:i386 libstdc++6:i386 libtinfo6:i386 libtirpc3:i386
  libunistring2:i386 libvdpau1 libvulkan1:i386 libwayland-client0:i386 libwayland-server0:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386
  libxcb-present0:i386 libxcb-randr0:i386 libxcb-shm0:i386 libxcb-sync1:i386 libxcb-xfixes0:i386 libxcb1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxml2:i386 libxnvctrl0 libxshmfence1:i386
  libxxf86vm1:i386 libzstd1:i386 mesa-vdpau-drivers mesa-vulkan-drivers:i386 nvidia-compute-utils-515 nvidia-dkms-515 nvidia-kernel-common-515 nvidia-kernel-source-515 nvidia-prime nvidia-settings
  nvidia-utils-515 screen-resolution-extra vdpau-driver-all xserver-xorg-video-nvidia-515 zlib1g zlib1g:i386 zlib1g-dev
Suggested packages:
  debtags menu glibc-doc:i386 locales:i386 krb5-doc:i386 krb5-user:i386 lm-sensors:i386 libvdpau-va-gl1
Recommended packages:
  libgl1-amber-dri:i386
The following NEW packages will be installed:
  dctrl-tools dkms gcc-12-base:i386 libatomic1:i386 libbsd0:i386 libc6:i386 libcom-err2:i386 libcrypt1:i386 libdrm-amdgpu1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386
  libegl-mesa0:i386 libegl1:i386 libelf1:i386 libexpat1:i386 libffi8:i386 libgbm1:i386 libgcc-s1:i386 libgl1:i386 libgl1-mesa-dri:i386 libglapi-mesa:i386 libgles2:i386 libglvnd0:i386 libglx-mesa0:i386
  libglx0:i386 libgssapi-krb5-2:i386 libicu70:i386 libidn2-0:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 libllvm13:i386 liblzma5:i386 libmd0:i386 libnsl2:i386 libnss-nis:i386
  libnss-nisplus:i386 libnvidia-cfg1-515 libnvidia-common-515 libnvidia-compute-515 libnvidia-compute-515:i386 libnvidia-decode-515 libnvidia-decode-515:i386 libnvidia-encode-515 libnvidia-encode-515:i386
  libnvidia-extra-515 libnvidia-fbc1-515 libnvidia-fbc1-515:i386 libnvidia-gl-515 libnvidia-gl-515:i386 libopengl0:i386 libsensors5:i386 libssl3:i386 libstdc++6:i386 libtinfo6:i386 libtirpc3:i386
  libunistring2:i386 libvdpau1 libvulkan1:i386 libwayland-client0:i386 libwayland-server0:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386
  libxcb-present0:i386 libxcb-randr0:i386 libxcb-shm0:i386 libxcb-sync1:i386 libxcb-xfixes0:i386 libxcb1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxml2:i386 libxnvctrl0 libxshmfence1:i386
  libxxf86vm1:i386 libzstd1:i386 mesa-vdpau-drivers mesa-vulkan-drivers:i386 nvidia-compute-utils-515 nvidia-dkms-515 nvidia-driver-515 nvidia-kernel-common-515 nvidia-kernel-source-515 nvidia-prime
  nvidia-settings nvidia-utils-515 screen-resolution-extra vdpau-driver-all xserver-xorg-video-nvidia-515 zlib1g:i386
The following packages will be upgraded:
  zlib1g zlib1g-dev
2 upgraded, 98 newly installed, 0 to remove and 5 not upgraded.
Need to get 32.0 MB/395 MB of archives.
After this operation, 1,114 MB of additional disk space will be used.
Do you want to continue? [Y/n]

Why does the driver depends on so many i386 (i.e. 32-bit) packages? How do I get the installation to rely solely on 64bit packages?

By the way, I get a package not found error for all these packages (for example)

Err:4 http://il.archive.ubuntu.com/ubuntu jammy/main i386 gcc-12-base i386 12-20220319-1ubuntu1
  404  Not Found [IP: 192.115.211.70 80]

Question Answer

No answer for now.

You may also like...

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.